Page :: Diary/2009 - 03 - 05

Diary/2009-03-05

[FSWiki]FSWikiLite用の複数行対応プラグインβ版

久しぶりに FSWiki ネタです。

fswiki-lite ver 0.0.12 をブロックプラグイン対応にします。

./plugin へ以下のファイルを追加
./lib/setup.pl へ以下を追加
1
2
3
4
5
6
7
 #===============================================================================
 # プラグインの設定
 #===============================================================================
 require "./plugin/core.pl";
+require "./plugin/_ex_block.pl";
 
 1;
ブロックプラグインのサンプル
  • pre.pl(182) - 2009/03/06-19:42:35
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
###############################################################################
#
# Wiki::Pluginの追加
#
###############################################################################
package Wiki::Plugin;

BEGIN{
    # ブロックプラグインのエントリ
    $main::B_PLUGIN->{pre} = \&Wiki::Plugin::pre;
}
#==============================================================================
# パース
#==============================================================================
sub pre {
    my $source = shift;
    my $args = @_;
    my $buf = "";
    $buf .= "<pre>\n";
    $buf .= &Util::escapeHTML($source);
    $buf .= "</pre>\n";
    return $buf;
}

1;
Comment
お名前: コメント:

トラックバック:Trackback(0)
タグ:

最終更新時間:2009/03/05-17:56:32